Subserver DNS trouble- New subservers don't work, domain changes don't apply, old ones work fine

My Virtualmin 3.75gpl (Webmin, Ubuntu 8.10) VPS with a domain and 4 subservers works fine - until I add new subservers.

It appears to work, I set up files without trying the URL, then a day later try the URL with a browser. It gives the ISP error screen for no domain found. The old subservers and main parent domain still work. Also, if I change the domain of a working subserver, the process appears to work (no errors), but nothing happens - old domain still found, new domain isn’t.

I’ve tried this both as root and a user and the result is the same. I’ve checked all config and settings and they’re all fine. I’ve restarted apache multiple times, rebooted the BIND DNS server, checked system logs (nothing stands out as looking wrong).

“System Settings > Re-Check Config” says “The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled” and no other errors or alerts, “… your system is ready for use by Virtualmin.”, “Validate Virtual Servers” says “All features OK” for everything, and the BIND DNS config checker in Webmin says “No errors were found in the BIND configuration file /etc/bind/named.conf or referenced zone files”.

The DNS records for my main domain look fine, as does the BIND DNS part of Webmin. I changed to ‘Yes’ the default template for always applying DNS settings (I forget the exact setting name). I’ve also deleted and recreated subservers countless times, before and after changing this, with the same result each time.

What could this be? It’s like the server is ignoring its own DNS settings. The only thing I can think of is maybe somehow a duplicate was created of some settings file which is overriding the one the Virtualmin interface is interacting with. Doesn’t seem likely (I certainly didn’t do it!)

When I set up the older subservers it worked immediately, and I’ve made no significant system changes since then.

Any ideas? Even ideas of where to look?


It could certainly be a DNS issue… one place you may want to start is to try inputting your domain name into “” to get a DNS report. It would let you know of any odd issues it sees.


Thanks for the reply,

Intodns says everything is fine for my main domain except for TLD Parent Check which gives “WARNING: Looks like the parent servers do not have information for your TLD when asked. This is ok but can be confusing.” - and from some research, it seems this is because my domain is and my nameservers (belonging to my host) are .net. I’ve never had any problems from this before.

Sadly intodns doesn’t give information for subdomains and it’s the subdomains that are the problem - my main domain loads fine, as do subdomains I set up with subservers before a month or two ago.

I’m stumped as to where the problem could be. As I understand it, if my main domain “” is working fine, then a request to “” first goes to .uk, then to the IP address assigned to, finding my server, then it looks in my server settings for and is re-routed to the appropriate sub-server (is this correct?) - and it’s this point where my server is failing, thinking there’s no record at all of a “” and so giving the same null response as if I’d typed “

If so, the only possibilities I can see is that somehow Virtualmin is failing to write to the correct files, or that the files it writes to are somehow being overridden. Which files in the filesystem are relevant for the initial routing requests for subdomains? I would have thought this would be the DNS records file, but that looks like its configured fine - are there multiple possible locations for this file?

No ideas?

This is a fairly serious problem - a whole area of Virtualmin reporting success, making changes in the interface, but seemingly not actually making any effective changes to the underlying settings.

Any help would be gratefully received! Right now my only options seem to be a complete re-install and hope, or replacing Virtualmin with a product that doesn’t have this problem.

Well, could you by chance list the sub-domain you’re having problems with? I’m having trouble coming up with guesses as to what the problem might be, but given the actual name, we should be able to determine what’s going on pretty quickly :slight_smile:

Once you get it working, you can always edit your post, and remove the name.