Subdomain virtual server

i recently installe virtualmin over Debian (i alreday did this with a ubuntu 10.04 LTS)
While i could create a virtual server for a subdomain on the ubuntu i restarted apache and all went ok

in Debian i did the same ting but nothing seem to work, i cannot access the virtual host on the Debian installation. I applied the changes under Server > apache > Apply Change and also did restart Apache, but still couldn’t access the subdomain, what did i forget to do? thank you for your advice.


What do you mean when you say you can’t access the sub-domain? What happens exactly when you try? What errors do you see?

Also, one would typically add a domain (or sub-domain) into their server using the “Create Virtual Server” option in Virtualmin.

Using Webmin -> Server -> Apache would be the hard way, and it may be easier to run into problems that way. Is there a reason you didn’t want to use Virtualmin to setup your domain?


sorry for not being clear enopugh,
i set up the virtual servers with Virtualminn of course.
For example, i created the virtual server, when i type into the address bar i first get a 303 http status, then since i use openDNS i get redirected to

the answer may lie here :
when i installe webmin i couldn’t do it under an account other than root
so for the main domain it was ok but for any subdomain, the group is not the same than the main domain, i will try to chenge the group and see if it works.

that is not working it says website not loading, it seems the subdomain is non existent. I can via putty access the directory, but not via ftp.
Any clue what i did wrong during webmin installation?thanks

when i try to access there is a 303 redirect.

i solved this problem
the domain was hosted on a registrar and i had to add the subdomain in the zone file and it worked.