Sub-server without parent name? or User creating top-level server?


I would like to configure Virtualmin so that a user (server owner) can set up a new server that shares the same disk quota and bandwidth.

Found how to set it up so the user could add a sub-server (that shares quota). But what if the user don’t want to have the parents domian name in the sub-server name? (like

Is it possible to have a sub-server without the parent name in the domain name? Or if it’s possible for a user to create a top-lever server? Or do the user has to a reseller to do that?

Looked at the documentation and the forums, but couldn’t find the answer… But I’m new to Webmin, so it’s possible I missed it :slight_smile:

Thanks in advance!



Don’t confuse the name Sub-Server with “subdomain”.

When a user creates a Sub-Server, there’s no requirement that it contain the domain name of the parent Virtual Server.

A Sub-Server simply means that it’s a Virtual Server that’s part of an existing account. So it does the quota and bandwidth sharing that you’re looking for. However, a Sub-Server can be any domain name (or subdomain name).

Does that answer your question?


Thanks for the super quick reply!

Yes, that answers my question. But when I try to add a Sub-Server, Webmin automatically extends the “Domain name” field with the parents name.

I figured that it was a template setting that did that. So I looked in System Settings -> Server Templates -> BIND DNS domain, but couldn’t find where to change it.


Ahh, it sounds like an Account Plan setting causing what you’re seeing.

In System Settings -> Account Plans, one of the options is “Allow sub-servers not under this domain”.

I suspect that may be set to “No” in your case.

You can change that for everyone by altering the Account Plan, or you can change that for just this one Virtual Server by going into Administrative Options -> Edit Owner Limits.


“Allow sub-servers not under this domain” was set to “Yes”. Both in Account Plans and Edit Owner Limits.
When I have it set to “No”, the parent name is pre-set when the page loads. And when I have it set to “Yes”, the “Domain name” field isn’t pre-set. But it still automatically extends the parent name when I click on something else.

I noticed that I had “Limit on number of virtual servers” set to “At most = 0” in Account Plans. Changed it to “Unlimited”, but it didn’t help…


Ok, so after a lot of trial and error I finally found the problem. And it was a silly one…

When I tried to make Sub-Servers I always used names like test1 or subserver2, without any top-level domain. But it turned out that when I didn’t have a top-level domain, Virtualmin automatically extended the name. So when I tried, it worked just fine… :slight_smile: