Sub Server Not found

OK, have had installed Virtualmin after using ensim/parallels for years and am still getting my head around it.
All domains have been successfully imported from my old server but subdomains weren’t (apparently they can’t be)… anyway I’m trying to set up new sub domains and I can’t get the browser to find the site once set up.
I created the sub server by selecting the parent domain, hit ‘Create Virtual Server’ / ‘Sub-server’
Named it ie.
I make sure there is no DNS bind and I have an externally hosted NS.
I can ftp to this sub server now but can’t view it in a browser.
The server has a number of IP addresses however most are shared. In this case the parent server has a different IP address than the majority so I assumed that the sub server would be on the same IP as the parent.
If I trace route the url it finds it.
Any ideas what I’m doing wrong here as I’ve got a number of sub domains to recreate and would prefer to be doing something else other than this as we roll over into 2012 :wink:

Noticed that it’s not that the URL is not being found but that when you put the subdomain in, it just goes to the parent site.


Noticed that it’s not that the URL is not being found but that when you put the subdomain in, it just goes to the parent site.

Hmm, that sounds like there may be a mismatch between where the DNS says the website is, and where Apache is listening for that site.

If you go into Edit Virtual Server -> Configurable Options, what does “External IP address” show? And is that the same IP that’s setup in your DNS for that sub-domain?


Thanks Eric… wasn’t too sure which IP that should be… I’ve changed it to the same as it’s parent site and no change… unless I have to refresh/restart something?

Well, your ISP’s DNS has likely temporarily cached that DNS record – so you may have to wait a day for the cache to clear (or have someone with a different ISP give it a try).


That’s what I thought but have tried from different ISPs and it’s been over a day now.
I tried setting up another sub server with the same parent and have the same problem… everything defaults to the parent site.
In the server list the parent and the subs list the same IP address, The DNS points to the correct IP.
Now under Edit Virtual Server -> Configurable Settings, the External IP of the subs is the correct IP address however the parent domain the the External IP as “Same as real address” which is the main IP address for the shared server.
If I check under Services -> Configure website the ‘Virtual Server Details’ Address is correct.
I’m sure it’s something simple I’m missing but any help would be appreciated.
Happy New Year BTW

Update: OK. I dumped the sub server and created a new virtual server with a subdomain name sharing the main shared IP and that worked.
I would, however, like to get the sub servers working on the parent IP.
Any ideas?

Any help? Is it a BIND issue… if so, any ideas how to fix? Am getting desperate here :expressionless:

Not sure if you resolved this, but the issue is probably with your domain registrar.
If you’re using private nameservers, you need to make sure that the nameservers are set to the private nameservers.
If you run the dig command, you should see if your subdomain has the correct a-record ip address.
e.g. for ip address x.x.x.x

;; ANSWER SECTION: 38400 IN A x.x.x.x