Stuck with gamin

History:

RHE 4 x64
New install including Virtualmin (and vmware)
/tmp to small to run virtual servers - needed to increase size
Increased size of Logical Volume by 2GB (For good measure and got loadsa disc space)
need to increase size of /tmp to the 2gb shouldn’t be a problem with a resize to full extend of the already extended logical volume.
But when trying to unmount the /tmp file various processes are running - most kill off OK with Virtual min users button - kill or terminate.

But the problem process seems to be gamin which wont die short of shooting it somewhere vulnerable in the hardware apparently. I have tried everything (as a serious newbie here so may have missed something) tried kill gamin at the prompt nothing, searched forums till I my fingers are raw and my eyes strained.

I can’t unmount the /tmp until I can get rid of this process and it’s now holding up the rest of the project so any help would be most appreciated!

Paul

Hi Paul,

gamin isn’t running on my system so I can’t see how it is started but you could try the following…

Try ‘/etc/init.d/gamin stop’

Try a ‘kill -9’ on the gamin process id (you should see this from ‘ps -x’. Do you get any message returned?

The ummount command has a -f option for forcing an unmount. You could try this but only if you were sure there was nothing else mounted that might corrupt something.

If all this fails try looking at the /etc/gamin/gaminrc file to try and see how it is configured. You should be able to change it so it doesn’t look at the /mnt/* path.
Maybe this is the best place to actually start :slight_smile:

Hope this gives you some thoughts.

Graham

I found a solution from Frank LaMon on the Red Hat users list and though I would put it on here for reference in case anyone comes across a similar issue.

In order to resize the /tmp folder I found out that the folder does not need to be unmounted in order to resize it.

Frank’s reply was :
>>>>>>>>>>>>>>
You don’t need to unmount the filesystem to resize it in RHEL4 - just increase the LV to the desired size and run “ext2online /tmp”
>>>>>>>>>>>>>>

When I did this it did in fact resize the folder to a larger size (although oddly not to the full extent of the increased 2GB created on the Logical Volume.

Still didn’t solve the stop gamin issue but at least the work around got the virtual servers running.

Paul

Paul,

Not sure but if it is running you should be able to find it in the runnin process section of webmin and kill it from there. I do not run gamin and am on a SuSE system.