Strange Virtual Server - just numbers?

Hi all

On my production server I’ve recently noticed a new addition to my list of virtual servers, but it isn’t one that I have created (to the best of my knowledge).

The virtual server name in the drop down menu of virtualmin has a random series of just numbers, with no TLD and when I go to ‘Edit Virtual Server’ it doesn’t have a domain name, admin username, home directory or any of the other features that I would have expected to be present. Also, under Edit Virtual Server > Enabled Features there are no filled checkboxes.

I’ve tried removing the virtual server via Disable and Delete > Delete Virtual Server, but it produces an error saying that Domain 131410…85 is not valid!. Can anyone point me in the right direction to remove this stray virtual server?

Cheers everyone.


That’s a bug that we’ve seen pop up on a handful of occasions. It’s so elusive that we haven’t been able to reproduce it.

We can, however, offer advice on how to kick that out of your domain list :slight_smile:

If you go into “/etc/webmin/virtual-server/domains”, you should see a file with that number you’re seeing in it’s name.

You can simply delete that one file, and then restart Webmin with:

/etc/init.d/webmin restart

As always Eric, spot on.

That bizarre server has now vanished - albeit the bug was more frustrating than a real problem :wink:

Cheers again

Well this just happened to me nearly 2 years later… still don’t have this one tracked down? It’s a wee bit disconcerting to be honest I had thought somebody had gained access to my server at first. However if that was the case CSF and mod_security would have gone nuts which it didn’t so it had me looking for the problem. Anyway if that’s the only place its referenced I’ll go kill it now.

I just had this happen to me as well. Approx five years using Virtualmin and it’s never happened before… very strange.

I can confirm that the above fix worked for me.

This has happened twice now. Now 100% sure, but I think that the cause was creating an alias server then using virtualmin to change it to a parent server. The conversion had errors and that is when I notice the numbers appear. The error was related to the email setup.

Hope this helps tracking the bug

Thanks for letting us know your findings!

We’ll do some testing to see if we can find a way to trigger that bug using your steps, though so far I seem to be able to change an alias to a parent without running into that issue.

It’s possible there’s another factor, along with those steps, that’s causing the issue – we’ll see if we can sort out what that other issue might be!