Strange Postfix issue "Relay access denied"

I am using Centos with Virtualmin pro (both latest/patched versions 5.x & 3.63) all domains have been moved as a result of a system failure in a different data center, so all the domains have been restored from Virtual Pro backups and all work perfectly except for 1 which is getting the error:-

Sorry, we were unable to deliver your message to the following address.

Remote host said: 554 5.7.1 <>: Relay access denied [RCPT_TO]

All of the other domains (20+) work and these emails for this 1 domain are being rejected from ALL incoming domains. Emails can be sent drom this domain OK, and are accepted from other domains also on that same server but not outside the server.
The website and everything else works perfectly just not the incoming emails.

Any clues ?

I have also been trying to look in the /var/log/maillog file but that is empty which is very strange, but is not affecting the other domains.



Am still confused by this, but deleting the domain & restoring it again solved the probem.

But any clues still welcome.


Hey Denis,

It is indeed very strange that your maillog would be empty.

Does restarting Postfix fix that?


No, I tried restarting postfix a number of times and still the maillog file is zero size.




I guess I’m curious what these two commands show:

postconf | grep syslog

grep mail /etc/syslog.conf