Strange Hosts Error

Hello, everyone!

I’m new to Virtualmin and installed it on a virtualized server recently with RHEL 6.4. After having stopped and restarted the service, I shut it down to perform a snapshot in vSphere. When I powered the machine back up, it was displaying a strange hostname: 127. When I ran system-config-network, it threw a few error lines of Python code. What’s more, I opened the DNS configuration to see that the Hostname had been changed to and the search domain had changed to 0.0.1. Finally, when I looked in /etc/hosts, I saw that the entries had gotten garbled with two extra localhost entries in line with the other entries. I removed the extras, and everything worked correctly again.

I’m here for knowledge, however: was it something in Virtualmin that caused this error? Is this something that anyone else out there has seen?

Thanks all in advance for your time and replies.


Well, it’s difficult to rule out some sort of Webmin/Virtualmin bug, but I’ll offer that I hadn’t heard of that happening before.

Rebooting shouldn’t cause that either – Virtualmin wouldn’t write to /etc/resolv.conf or /etc/hosts unless making updates in Webmin -> Networking -> Network Configuration.

Out of curiosity, after fixing those issues, does the problem come back after performing a reboot?


It does not.

I’ve rebooted a couple times since then, and the correct hostname remains in place.