Storing to S3 fails

I noticed recently that Virtualmin added multi-part upload and mutli-level backup directories. I have 3.94 so I thought I’d try since s3cmd sync is not quite working for me. But Virtualmin fails. It sent 6 of the 14 files generated during the backup each of the last 2 nights. I changed this 2 nights ago so I was expecting results for the 15th and 16th. It also failed to create a backup log file. I see the resulting files, as I mentioned, so it must have run, but under backup logs there is nothing.

I’m backing up to local and then adding a destination to S3. Since some things made it to the S3 bucket then my credentials must be correct. Here is my bucket path:
See attachment for settings, log results screen, and what ended up in S3.

There should be one file that is 34GB and the rest are no bigger than 8KB for each night. I can see all the files fine on the local store.


Well, there’s been a lot of backup and S3 fixes over the last few Virtualmin versions.

I don’t know for sure if it’ll fix the specific issue you’re seeing, but it might!

My suggestion would be to upgrade to the most recent Virtualmin version, and see if that resolves your issue.

If not, let us know and we can look into that further.

However, hopefully, one of the many fixes Jamie put into recent Virtualmin versions will fix that!


I just updated to 3.94 last Friday and the system info page on Virtualmin says there are no more updates. How would I get a newer version?

Hmm, well, Virtualmin 3.94 is about 6 months old… which Linux distro is it that you’re using?

And how did you perform your Virtualmin install, did you use the script for that?


I inherited the system. Looks like they did this, oh, more than a year ago:
sudo sh

Ubuntu 10.04.4 LTS
Part of sources.list:
deb lucid-updates main restricted universe multiverse
deb lucid partner
deb virtualmin-lucid main
deb virtualmin-universal main

Hmm, that sources.list looks correct at a glance… but I can also confirm that the latest Virtualmin is in that repo.

So something is awry :slight_smile:

What happens if you log into the command line as root, and run “apt-get update && apt-get upgrade”, are you then prompted to upgrade to the most recent Virtualmin?


Not sure I can just do that right now. Strict controls on our production server so we don’t upgrade something that might break a function. Is there a way to look without doing?

I launched a new copy of the production server on Amazon and tried the command:

sudo apt-get update && apt-get upgrade

Reading package lists… Done
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Did sudo su instead then ran:
apt-get update && apt-get upgrade

The following packages will be upgraded:
libfreetype6 libfreetype6-dev libnspr4-0d libnss3-1d
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,643kB of archives.
After this operation, 86.0kB of additional disk space will be used.
Do you want to continue [Y/n]?

So I ran those updates (no Virtualmin) and the Virtualmin system screen says there are no updates to be had and Virtualmin is up to date and at version “Virtualmin version 3.94.gpl GPL”.

Hmm, can you paste in the output you receive when running “apt-get update” (as root, or with su/sudo)?

Something is awry, but I’m not sure what yet… seeing the apt-get update output may show some clues as to what’s going on.


Hit lucid Release.gpg Ign lucid/main Translation-en_US Ign lucid/universe Translation-en_US Get:1 lucid-updates Release.gpg [198B] Ign lucid-updates/main Translation-en_US Ign lucid-updates/universe Translation-en_US Hit lucid Release Hit lucid-updates Release Get:2 lucid-security Release.gpg [198B] Hit lucid Release.gpg Hit lucid/main Packages Ign lucid-security/main Translation-en_US Ign lucid/main Translation-en_US Get:3 lucid/universe Packages [5,430kB] Ign lucid-security/universe Translation-en_US Hit lucid Release Get:4 lucid-security Release [57.3kB] Hit lucid/main Packages Get:5 lucid/main Sources [659kB] Hit lucid/universe Sources Get:6 lucid-updates/main Packages [663kB] Hit lucid-updates/universe Packages Hit lucid-updates/main Sources Get:7 lucid-updates/universe Sources [106kB] Get:8 lucid-security/main Packages [473kB] Get:9 lucid-security/universe Packages [167kB] Get:10 lucid-security/main Sources [133kB] Get:11 lucid-security/universe Sources [43.8kB] Fetched 7,732kB in 7s (1,030kB/s) Reading package lists... Done

Hmm, I don’t actually see the Virtualmin repository mentioned in any of that.

I know you mentioned above that you saw the Virtualmin repo in your sources.list, but it doesn’t appear from the above that it’s seeing those lines for the Virtualmin repository.

You may need to post your entire sources.list file, including the Virtualmin part, in order for us to see what’s going on with that.


That may be it. The sources.list file was not correct. We have found that Amazon instances when restored get the sources.list file overwritten for some odd reason. I forgot to go back and overwright the sources.list file with the master copy that we use. The one I included before was that master copy. Anyway, after putting the proper sources.list file in place, Virtualmin indeed reports that there are 3 updates.

webmin-virtual-server Webmin module for 'Virtualmin Virtual Servers (GPL)' New version 3.97.gpl-2 Virtualmin webmin-virtual-server-mobile Webmin theme 'Virtualmin Mobile Theme' New version 2.5 Virtualmin webmin-virtualmin-awstats Webmin module for 'AWstats Reporting' New version 4.8 Virtualmin

Installing them brings my test server to 3.97. I assume that is the latest then?

The odd thing to me now is that this proper sources.list file should have been used in our process last Friday but the updates did not go that route. Will have to investigate.

What are the chances that updating Virtualmin packages on the production server could be harmful?

I made the change to the production server overnight. Virtualmin is at 3.97 now and the save of the backups to S3 is working. It sends all 14 files one of them being 34GB.