startx failure


Does the VMPro install disable the Xserver? WHen I did this install I put on the desktop environment so I can work on it through KDE but the xserver fails. Was wondering if it was VM or the CentOS install.

Hey Dan,

Nope. We don’t care at all about X and there’s nothing in the Virtualmin install that would tamper with your X configuration.

I didn’t think so, but had to ask. My impression of the CentOS install disk is that it does a good job of laying the footwork for the VMPro install, but that’s about it. It may have to do with me using the Server_CD iso but then why ask if you’re not going to install it :frowning:

Oh, yeah. Server CD doesn’t enable X, by default. It starts in runlevel 3.

I believe you can just change it (assuming you did install X) by editing /etc/inittab and changing this line:


To this:


A reboot should bring up X (unless something is broken in the configuration).

I gave that a whirl and on reboot got a complanint of something respawning too fast disabled and waiting 5 minutes

It’s no biggy on this box and I’ll have to experiment on a different clean one then.

Hey Joe,

I realized that the centos server cd may ask if you want to install the startx but doesn’t really do it. I used the standard ISOs to install on another box and was able to install xserver and a desktop. THen I remembered why I didn’t want the xserver in CentOS. Apparently it runs all the time as a shell (like windows) and you have to open up a window to get out into the system and that’s not what I wanted either. I only wanted to bring up a GUI desktop when I needed it. :frowning:

I noticed that on my CentOS install, the server install CD ( only installs the bare minimum for Xserver.

I had to do:
yum groupinstall "X Window Server"

To get all of the X packages to allow X to run properly.


Dan - why not have the server start in runlevel 3 and then init 5 when you want to use the x server?

I’d installed the servercd iso and apparently it asks if want to install the client but doesn’t install the xserver so when I went to level 5 it kept looping out on error. When I get time I’ll try it again, but I’m pretty sure that’s what happened. It worked fine when I used the 4 disk set. Operator error :wink:

That’s what I was saying - Install regular version then edit conf files to start in runlevel 3. Then just whenever you want to bring up x server just init 5…