SSL on Forwarding and Oauth for Forwarded Servers

OS type and version: Ubuntu 20.04 LTS
Virtualmin version: 6.13

Hey guys,

I’m new here, testing Virtualmin to start implementing web hosting for my clients, i’m on the GPL version to test if i can do what i need and then of course will go to the Pro version, so far i really like Virtualmin and i think it’s a great tool.

So i have this 2 very specific doubts with virtualmin, at the moment i have a HW FW that redirects ports 80 and 443 to a VM running Nginx, that is at the moment handling the traffic and the let’s encrypt certs, this VM redirects to another VMs depending on the domain and service is requested, that’s the current setup.

Since i want to do some web hosting, the plan is to set it the following way: HW FW redirecting port 80 and 443 to VM with Virtualmin to handle traffic/SSL and redirections to this other VMs with other apps.

i can see that i can redirect to other local Ips if i create a new virtual server for the specific domain, but can i use any other auth method before redirecting to the backend VM? like authelia/basic auth? since i have several other VMs the idea is to have it integrated with Virtualmin, but i couldn’t find anything regarding this.

And the second question is, can Virtualmin handle the Certs for those redirected hosts? i believe it can just haven’t tested yet.

And thanks for creating such a time saving tool!

Hello guys, any idea about the SSL Passthrough?

Managed to verify how the simple forward works, i can forward an http request to another local server, but can’t make the SSL from Let’s encrypt validate for the forwarded servers, for any other website works ok, but not when i do a forward… @unborn i believe you have some experience with this, what would you charge me to solve the issue and document the steps to make it work in the future if we need to do another forward to another server?

1 Like

@Dinamic thank you for your time and question. I would like to ask - you looking for host everything via https on front (one public ip) and behind within your lan on private ips? still able to renew ssl from lets encrypt? I do work with apache only I am afraid. Its nothing against nginx its just my knowledge on nginx is limited. I would ask £40 for implementation + written documentation + video documentation. I can be with you via zoom, teams, google meets or teamviewer call (shared screen, not remote control unless you specifically would wish otherwise), let me know if that is doable for you. There is always option to support virtuamin guys by opening ticket with them. Currently I have no idea what they charging but I am 100% sure they could help as well. I am free mo-fri 8:00-21:00 UK time, sat-sun 10:00-23:00 UK time - let me know what time would be best for you and how would you prefer me to call you (no zoom, google meets or teams need to be installed) perhaps you would like to have a small chat with me before even proceed if you have any additional questions about this. Please feel free to contact me at any time you might want. By email directly is fine. I think everything is mentioned on my profile here.


Edit: that chat before process - is of course free, no money or anything like hidden… its just to found out if my know-how is right for your needs and to make sure we are on same picture regards your requests.

That’s exactly what i want and yes, 1 public IP, since i already have a couple of local servers and i’m using nginx as reverse proxy and to manage the certs, the idea was to move from that nginx (that’s just working as proxy) to webmin/virtualmin and let it manage the certs and the forwarding along with website hosting, but the SSL passthrough is what is blocking me so far, the next will be .net core and some form of authentication prior to forwarding to those servers (authelia maybe? not sure what to implement here), but hey, i’ll send you a private message with my email/phone and let’s chat, maybe you can also help me solve the other issues too.

1 Like


As the side question – how in the world is it possible to misfill-up the template for system information and software versions?

I fixed it for you but could you please be kind explaining how is it even possible? I need to understand that, so maybe I could fix or improve it somehow to prevent this from happening in the future?

This is what it was before –


This is what it’s expected to be –


@Dinamic I would love to help you. Send me pm any time you would be ready.

I use also telegram or signal (sorry no whasap on my end). Best would be to find out when you are free for zoom or teams call so I can share my screen or you with me, so we get all information right up so we can focus on the issue it self.

thank you.

Thank you Ilia! well… it’s fairly simple, it’s a UX “issue” cause is not actually an issue but rather a perspective or point of view thing, whenever you create a new post, what do you see? well the following:

The red arrow is where you should type the info, but the blue arrow is where it comes to mind, why? i was thinking about a form, not code and was in a bus while creating the topic, first topic btw… so yeah, that how in the world i misfilled the template :joy:

You’re right. There was a bug. I fixed it and all other templates around all categories.

Thanks. Sorry.

1 Like

Thank YOU for continuing to improve things man.

Due to a personal issue (not related to the job, just a personal matter), Unborn won’t be able to help us with this, is there anyone up to the task?

Issue solved, thanks to all who where willing to share their knowledge, specially @tpnsolutions for setting me on the right path :wink: