SSL installed, but no padlock

I have setup my SSL certificate for my domain which can be read by browsers. Only the problem is that it is not showing the padlock.

Normally i work with Directadmin, httpd, postfix etc. hand installed and that means when i create a user within Directadmin the user gets a private_html folder for its SSL files. But with Virtualmin, it does not create such folder.

The certs and keys etc are stored in the root of the home folder of the user domain. Like /home/domain. The website files are stored in /home/domain/public_html.

It loads the website, reads the freshly installed cert, but does not load the padlock. So when i go to www.whynopadlock.com it says:

Valid Certificate found.
Certificate valid through: Feb 20 23:59:59 2016 GMT
Certificate Issuer: COMODO CA Limited
SSL Protocols Supported: TLSv1 TLSv1.1 TLSv1.2

So thats good. But it also shows me 118 errors:

Total number of items: 118
Number of insecure items: 114

Insecure URL: http://domain.com/catalog/view/theme/OPC040084/stylesheet/megnor/tm_flexslider.css
Found in: https://domain.com/

Insecure URL: http://domain.com/catalog/view/theme/OPC040084/stylesheet/megnor/custom.css
Found in: https://domain.com/

Insecure URL: http://domain.com/catalog/view/theme/OPC040084/stylesheet/megnor/carousel.css
Found in: https://domain.com/

etc. etc.

So i thought, let me place the website files to the root /home/domain, but nope, still same problem. I checked all setting like in Services, the SSL certificate manager under Server Configuration and the excisting virtual hosts under Webmin - Apache webserver. They all seems to be fine.

Does anyone has any idea how i can handle this? I’m sure it’s a tiny setup i’m missing here, but working on it for 6 hours now and i become a little frustrated about it :slight_smile: so hopefully someone can shed some light here…

Hmm, after 6 hours and the time i have spent on above message, i finally got an ureka moment and checked the config files of Opencart…the https server wasn’t right configurated, dah.