ssl installation in virtualmin

hello.

i want to install ssl in my virtualmin so buy new ssl from comodo

install successfully but still not able to access https:// address with site can anyone help here ??

Howdy,

What happens when you try to access the https:// site? Do you receive an error of some kind?

-Eric

When i try to access https:// its load page long time and gives white page

Howdy,

It sounds like there may be a firewall of some kind blocking access to port 443.

Is your server running a firewall?

Or is there maybe a firewall/router in front of your server that’s either blocking that port, or not performing port forwarding?

-Eric

no i have no firewall install on server

also i used this code for this:

iptables -A INPUT -p tcp --dport 443 -j ACCEPT
/sbin/service iptables save
iptables -L -v

i did check all my setting , everything working fine still not able to connect with https:// address any update ??

Hello ,

I solved the above problem , that was CloudFlare which were blocking to connect https:// as they not provide ssl service for free plan , after switching off cloudflare its worked !!!

i have a additional question … site working with https://www.domain.com not with https://domain.com any idea ??

see attachment file *

If you switched off cloudflare, it could just be DNS hasn’t fully updated yet. I would double check the DNS records exists (A records) and are properly configured.