SSL certificate installed, but self-signed certificate is only being used?

I have installed an SSL certificate via manage SSL certificates, however whenever navigating to the website the self-signed certificate still shows up, not the new SSL cert.

Other SSL websites on this server work fine as well. Any ideas as to why this is happening?

I have also looked at etc/httpd/conf/httpd.conf and everything looks correct, it is pointing to the new SSL certificate i.e.

ServerName ServerAlias ... ... SSLEngine on SSLCertificateFile /home/TheWebsite/ssl.cert SSLCertificateKeyFile /home/TheWebsite/ssl.key

Any help would be greatly appreciated, thank you!


You may want to make sure it’s not just an issue of Apache not being restarted… you may want to try running this command:

/etc/init.d/httpd reload

After that, does it begin working?


Hi Eric,

That was actually my first thought too but restarting it didn’t fix it. Any other ideas?

after looking at the certificate I’m not even sure what to make of it. I’ve attached a screenshot from firefox. Anyone got any ideas?

The post that you saw over here:

Has someone who found that the SSL key/cert path setup in /etc/httpd/conf.d/ssl.conf on their CentOS system was overriding what was setup in the VirtualHost block for their domain.

They opted to edit ssl.conf to set the paths to point to their preferred SSL cert/key, though if that’s indeed the issue in your case, you may simply be able to comment them out in that particular file.

Does doing that, followed by restarting Apache, by chance solve your issue?


Eric, I removed:

<VirtualHost _default_:443>

and it works fine now.

I can verify even before I removed it SSL worked fine for any IP's that are not shared, which is why the other domains on the same server with SSL worked fine, but since I wanted SSL for the main IP which was shared, the default overrode it.

Odd bug, using centos 5.5 as well as virtualmin install from </p>