SSL certificate and FQDN

Yesterday I took advantage of the Namecheap/Comodo positiveSSL certificate available for free with the GitHub developer pack. I recommend others do the same! However, having largely followed the instructions for installing an SSL cert in the docs (I ignored the change IP address bit – I have 1 IP), my self-signed cert still seems to be being served.

If my domain is, and my FQDN is, is there any reason why my cert for cert isn’t working? I read somewhere that using my FQDN for SSL is generally a bad idea, but is there anything I can do?

The main reasons I’d like SSL are for TLS web logins and SSL IMAP access.


If the domain your trying to secure is then your SSL certificate (which if I am looking at the correct promotion that you are referring to then the SSL certificate only covers one domain) and it sounds like you issued the SSL for, which means will work fine but isn’t covered by that certificate.

Hope this is helpful,

Thanks Dustin. It’s my site with which I would like to use SSL. I just also mentioned the FQDN in case it was the root cause of the issue. I’ve enabled SSL website for, generated a CSR, and uploaded succesfully the cert in Virtualmin, yet the self signed cert is still being served…

Do I need to manually delete the self signed cert?


Would you mind providing the real URL you are trying to secure so that I can see what is being provided to the browser? And no, Virtualmin should overwrite it when you upload your own.

When you say FQDN, are you referencing your servers hostname?