SSI not working

I’m sure I’m missing something…

I have a one line example file test.shtml:
<!–#echo var=“DATE_LOCAL” -->

The virtual server has both Server-side includes and execs and Server-side includes set. Confirmed that the Options Includes was added to the appropriate sites-enabled file.

And yet … no love. View source on fetching the page shows me the <!-- --> line above, not the date that it’s supposed to be replaced with.

What am I missing?

Ubuntu 10.4, VirtualMin 3.82.





You’d also want to make sure that Apache has the “include” module enabled. You can do that by running this as root from the command line:

a2enmod include

After that, you’d also need to restart Apache. Does that by chance fix up your issue?


You’re my hero. :slight_smile: Got it in one. (KInda surprised that module’s not on by default, but … whatever.)

Many thanks.