SSH virtualmin backup

Hello, i am trying to backup my server to remote server via ssh option, my ssh port is custom and i get this kind of error

Starting backup of 1 domains to /backups/backup-%d.%m.%y.tar.gz on SSH server

Failed to connect to SSH server : ssh: connect to host port 22: Connection refused lost connection

How can i solved this ?

Have you tried changing the “Server port” : default option to the port on your ssh server?

I am using ssh with custum port to connect to server, what you mean about that ?

Right there on the backup page, when you select the ssh option, below it you can set the port to use. From your log above, you didn’t do that. I’m suggesting you try it, or at least tell us if you did. :slight_smile:

Hello, i have doubled checked and cant find anything where to change ports. Check link with image


what does it say when you include port with hostname ( ssh server field ) . e.g.

Hello, this what i get

Uploading archive to SSH server myipadress hiden…
… upload failed! user@myipadress hiden’s password: scp: /backups/backup-24.10.17.tar.gz: No such file or directory

Backup failed! See the progress output above for the reason why.

It doesn’t get port portion like it doesnt exisit.

I have tried via scp command line and its working just fine

No issues here doing hostname:port in virtualmin scheduled backups. I to have non standard port number.

Those 2 errors you listed are different. The 1st says cant login at all. The 2nd says cant find the folder. Which is it? So on the second, Looks like login works now so just make sure the folder it is looking for exists on the destination. I can tell you the path /backups/backup-24.10.17.tar.gz is wrong. It has to be full path. like /home/username/backups/backup-24.10.17.tar.gz

Hello. thank you so much. I was thinking that if i have user that logs via ssh then there is no need for full path.

Another question that i have is that i have checked all for backup but cant find public_html files when backup is moved to another server.