Special chars on same server different !?

Hello @all,

i administrate one dedicated server with virtualmin. it’s running several domains on 2 ip addresses.

On the first IP nearly all domains are running - everything works fine for years now … but:

After moving (also tried creating a new) domain on the 2nd IP and saving files with PHP or FTP, special chars like “§” within those files are converted to “§”. Using the “nano” editor via SSH on the server, saving a test file with those chars and opening the website (file), all chars are shown fine.

For testing this, i used this PHP script:
$file = fopen(“test.txt”,“w”);
fwrite($file, “§§”);

Result on the 1st server = “§§”
Result on the 2nd server = “§§”

Also tried php commands like “utf8_encode”, but it’s not working.

I compared the apache2, php.ini files and checked twice other settings. All are the same (of course except the paths and usernames, …). The hardware is the same, PHP only uses different ini-files (which i compared), apache2-server is the same.

What is the problem, where didn’t i looked into ?

Thanks for your ideas and solutions.