spamc apparently not working

Spamassassin standalone works well, but I am getting some high cpu loads during business hours when everyone is using their email.

So I switched to using the scanner (selected spamc), the spamassassin scanner server is on, host set to localhost… but when I look at mail, their are no spamassassin related tags.

No errors in miniserv.error.

Any thoughts?

Do you see the spamd process running?

Any errors regarding it are likely to show up either in the mail log (either /var/log/maillog or /var/log/mail.log), or in the procmail log, /var/log/procmail.log.
-Eric

Yes, I get:

2759 root 0.0 % May21 /usr/bin/spamd -d -c -m5 -H -r /var/run/spamd.pid
2797 root 0.0 % May21 spamd child
2798 root 0.0 % May21 spamd child

when spamd is searched for in processes.

Under ‘spam and virus scanning’, there is a ‘disable spamassassin server’ button.

Spamassassin Filter Server shows up under ‘status’ on the ‘system information’ page.

I don’t find any spamd related lines in the procmail log.

No spamd related errors in maillog. Just lines indicating it started ok.

But I get no spamassassin tags or score in the emails, neither header nor body…

… I’m also NOT getting a ton of spam though. Could the spamassassin scanner be working but not tagging emails? Is there a different config for the scanner than for the standalone?

opps, double post, sorry.

Hmm, so is any new spam going into your spam folder?

And in your email headers – there’s nothing starting with “X-Spam-Status” in there?

Are you sure that the Spam and Virus feature is enabled for this Virtual Server?

Lastly – in your maillog, does it contain the word "spamd" at all?

Just some thoughts!
-Eric

oh, I do have postgrey on to, that’s why the spam count is still low.

Correct, X-Spam-Status is not on any headers when spamassassin scanner is on. If I switch to the standalone version is it there.

Confirmed that spam and virus filtering is enabled on virtual server(and works with standalone).

Yes, the last few lines in maillog related to spamd are:

May 21 19:45:25 jessica spamd[2757]: logger: removing stderr method
May 21 19:45:40 jessica spamd[2759]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": report_header 1
May 21 19:45:42 jessica spamd[2759]: spamd: server started on port 783/tcp (running version 3.2.5)
May 21 19:45:42 jessica spamd[2759]: spamd: server pid: 2759
May 21 19:45:42 jessica spamd[2759]: spamd: server successfully spawned child process, pid 2797
May 21 19:45:42 jessica spamd[2759]: spamd: server successfully spawned child process, pid 2798
May 21 19:45:42 jessica spamd[2759]: prefork: child states: II

is it = it is

ie: the spam headers are there when the standalone version is on. And not there when the scanner is on.

Aha!

There appears to be an error in the spamassassin config – in "/etc/mail/spamassassin/local.cf".

Is there a line that looks like: report_header 1

If so, try commenting that out, and restart SpamAassassin.
-Eric

We discussed that one already :slight_smile: here:

http://www.virtualmin.com/forums/general-discussion/spamassassin-report_header.html

However, though the report_header works in the standalone version anyway, I wonder if it doesn’t in the scanner, would that make sense?

Testing…

Ahh, that does ring a bell :slight_smile:

As far as why it works in standalone mode – I’m not sure, I’ll try and tackle that question if we discover that your problem goes away if you comment that line out :slight_smile:
-Eric

Well, still haven’t tracked this down.

It looks like either starting the scanner or installing 3.69 gpl update rewrote a little bit of the local.cf file.

It added: report_safe 1

which is:


if this option is set to 1, if an incoming message is tagged as spam, instead of modifying the original message, SpamAssassin will create a new report message and attach the original message as a message/rfc822 MIME part (ensuring the original message is completely preserved, not easily opened, and easier to recover).

If I understand that, it would put the original email into an attachment and sent it to me that way, but that isn’t happening.

Regardless, I switched it to:

if this option is set to 1, if an incoming message is tagged as spam, instead of modifying the original message, SpamAssassin will create a new report message and attach the original message as a message/rfc822 MIME part (ensuring the original message is completely preserved, not easily opened, and easier to recover).

report_safe 0

which is:


incoming spam is only modified by adding some X-Spam- headers and no changes will be made to the body. In addition, a header named X-Spam-Report will be added to spam. You can use the remove_header option to remove that header after setting report_safe to 0.

because what I want is the score/report in the headers so I can just take a quick look to see what is going on, but otherwise the message should be left alone.

But after restarting spamassassin, I’m still not getting the headers, so I don’t know…

It must be some setting in the config file, I’ll keep playing with it and figure it out. I’m tired of it right now. I think spamassassin scanner is working, just not giving me the header report.

Thanks again for all your help and suggestions Eric.

oh, and the depreciated report_header 1 I did take out.

Well, you previously posted some details from the maillog regarding SpamAssassin, that showed an error:

spamd[2759]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": report_header 1

Are there any SpamAssassin errors showing up still?
-Eric

No, after taking that ‘report_header 1’ out, and replacing it with ‘report_safe 0’, no errors.