Spamassassin SQL user_prefs not working

Hi. I can’t get my SQL user_prefs to work. Am I correct to assume that I have to use spamd instead of spamassassin if I want them to work?

Aside from that, it seems like spamd is being run without -q even though I have configured the Spamassassin server to use a MySQL database. What could be the problem?

Virtualmin 3.97 gpl
Webmin 1.600
Debian 6.0.6


It’s spamassassin, rather than spamd, which can do the per-user settings.

However, if it’s using SQL, I suspect either should be able to work.

If spamd isn’t running with your desired options, you’d need to edit “/etc/default/spamassassin”, and tweak the OPTIONS= line to have all the options you need. Then restart SpamAssassin with:

/etc/init.d/spamassassin restart