SpamAssassin not changing Subject or headers

Hi. When I get a message that spamassassin identifies as spam, the subject (and headers) are not changed at all even though the option is set spamassassin’s config file. An excerpt from my /var/log/maillog:

Aug 6 14:51:07 getkratom spamd[7115]: spamd: connection from localhost [127.0.0.1] at port 56249 Aug 6 14:51:07 getkratom spamd[7115]: spamd: setuid to getkratom succeeded Aug 6 14:51:07 getkratom spamd[7115]: spamd: processing message <000d01ca16c6$d96856f0$6400a8c0@overseenpzdy27> for getkratom:500 Aug 6 14:51:07 getkratom postfix/smtpd[10476]: disconnect from adsl190-28-246-244.epm.net.co[190.28.246.244] Aug 6 14:51:07 getkratom spamd[7115]: spamd: identified spam (5.1/5.0) for getkratom:500 in 0.2 seconds, 5801 bytes. Aug 6 14:51:07 getkratom spamd[7115]: spamd: result: Y 5 - HELO_LH_HOME,HTML_MESSAGE,MIME_QP_LONG_LINE,RDNS_DYNAMIC scantime=0.2,size=5801,user=getkratom,uid=500,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rport=56249,mid=<000d01ca16c6$d96856f0$6400a8c0@overseenpzdy27>,autolearn=no Aug 6 14:51:07 getkratom spamd[7110]: prefork: child states: II Aug 6 14:51:07 getkratom postfix/local[10482]: 6557A229039: to=, orig_to=, relay=local, delay=1.3, delays=0.91/0.01/0/0.37, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME) Aug 6 14:51:07 getkratom postfix/cleanup[10481]: 1CB2622903A: message-id=<000d01ca16c6$d96856f0$6400a8c0@overseenpzdy27> Aug 6 14:51:07 getkratom postfix/qmgr[6816]: 1CB2622903A: from=, size=5979, nrcpt=2 (queue active) Aug 6 14:51:07 getkratom postfix/local[10482]: 6557A229039: to=, orig_to=, relay=local, delay=1.4, delays=0.91/0.01/0/0.44, dsn=2.0.0, status=sent (forwarded as 1CB2622903A) Aug 6 14:51:07 getkratom postfix/qmgr[6816]: 6557A229039: removed

The message then gets forwarded to my personal email account unmodified. Any suggestions?

Howdy,

Which options do you have set in your spamassassin config?

And which spamassassin config are you adding those to?

Thanks,

-Eric

The config file is /etc/mail/spamassassin/local.cf

Contents:

These values can be overridden by editing ~/.spamassassin/user_prefs.cf

(see spamassassin(1) for details)

These should be safe assumptions and allow for simple visual sifting

without risking lost emails.

required_hits 5
report_safe 1
rewrite_header subject [SPAM]

use_bayes 1

Enable Bayes auto-learning

bayes_auto_learn 1
bayes_path /home/spamd/bayes
bayes_file_mode 0666

Enable or disable network checks

skip_rbl_checks 0
use_razor2 0
#use_dcc 0
use_pyzor 0

#header SMILE_FACED_SUBJECT Subject =~ /\b:)\b/
#score SMILE_FACED_SUBJECT 0.1
#describe SMILE_FACED_RULE Block the spam who’s subject is a smile face

dns_available no

Hrm, well, that looks pretty good.

The only thing I see, is that in the SpamAssassin docs, they use “Subject” with a capitol “S”:

rewrite_header Subject

http://spamassassin.apache.org/full/3.2.x/doc/Mail_SpamAssassin_Conf.html

You might try making the S upper case, and restarting SpamAssassin.

-Eric

Thanks for the suggestion. I just tried it, but it still isn’t working.