Spam filter not created for some users

For my email account I have a filter “Email is spam” that I cannot edit. Its automatically created.

Other users I have on the server do not have this. Their spam is not filtered. but I have enabled spam filtering for their account, and their preferences say to filter spam. I cant see for the life of me how to enable this spam filter rule.

So I have to manually create a rule for them “Email is spam” -> “Save in folder spam”

Seems a bit strange its not filtering automatically like my own email, and I have to create a rule?


I know its very old but I still have this issue. I must have forgot about this above, and just noticed it again and just found this post on Google.

So anyone know about this?

x-Spam headers are not added.
The Gtube test thing does not get filtered.

So on the users with no spam filters created, I dont think its checking spam. But spam checking is enabled on the account and the user.