Spam Checking turned on for a domain, turned off for a user, but still blocking

I’ve got a domain that has, in the spam settings, the destination set to: Write to standard spam Maildir ~/Maildir/.spam/

I’ve got a user in that domain set to: Check email for spam and viruses? No

That user is still getting spam put in the ~/Maildir/.spam/ folder.

Is there something I’m missing on the setup?

I can’t seem to resolve this.

The other behavior i’m seeing is that if the message is marked as spam, it is hitting the spam folder and stopping processing. I’ve got: “Deliver to this user normally:” -> Yes, deliver to mailbox set up and also “forward to other addresses” email set up to a gmail account for testing. It’s getting the mail, marking as spam, and not forwarding.

Also, Is there a manual alternative (like editing the user’s spamassassin settings from the commandline) to get this at least working outside of virtualmin?

has this not to do with how the spamassassin is working? If its running for serverwide (spamd) you can not adjust for a client.
While running as standalone program, you can
That’s is how i understood it anyway