Spam boxes keep growing

Although i’ve set “automatically delete spam” to 7 days, the spam is not deleted after 7 days. What can be wrong?

Well, there’s two places you can set the delete spam bit.

One is in the Server Templates. The Server Templates generally specify the defaults to use when a new server is created – they aren’t yet able to modify parameters for existing servers.

What I would suggest then is to go into Virtualmin, choose a given domain name, then click Server Configuration -> Spam and Virus Delivery – and verify that "Automatically delete spam?" is set to the number you want for that domain.
-Eric

I’ve cheched those for all domains and still mail stays on the .spam folders longer than 7 days.

Okay.

If the domain settings claim that it should be deleting after 7 days, and it’s not, that sounds suspiciously like a bug.

I’d file a bug report for that in the tracker:

http://www.virtualmin.com/bug-tracker/

Thanks!
-Eric

Thanks, will do