spam assassin

I have two servers setup with Virtualmin Pro on each.

Server A - hosts websites, web and email home directories on local filesystem.

Server B - LDAP server, mail server and /home/ NFS mount to server A

DNS MX records for hosted domains dictate that mail should be sent to Server B. This works.

The issue I am having is that spam assassin is not being run on Server B for incoming messages. Is there some special wiring I need to apply to spam assassin to make scan emails??

spam assassin is running (of course), it just doesn’t appear to be invoked each time a message comes in.


You’ll want to make sure that in System Settings -> Features and Plugins, that “Spam Filtering” is checked.

From there, within any given Virtual Server, in Edit Virtual Server -> Enabled Features, “Spam Filtering Enabled” needs to be set.


Hi Eric,

Yes the spam filtering is enabled in Features and Plugins.

I think it is because the email coming in is destined for virtual servers located on server A.
Because in features and plugins it appears to only list the domains that are on server B (which is just 1)

spam assassin works on the postfix system that contains the virtual server, but fails to work on another, even tho both systems share the same LDAP user information.

I suspect that this may have something to do with “Spam Filtering enabled?” checkbox under the enabled features when you ‘Edit virtual Server’ – as this is only available one on the servers, not both.

How do I get the other system to read the enabled features for a particular domain not hosted on that server?

does this make sense?