Some have the PHP-fpm option , Some do not?

What would be causing some virtual servers to have the php-fpm option and some do not?

Operating system CentOS Linux 7.6.1810
Perl version 5.016003
Path to Perl /usr/bin/perl
BIND version 9.9
Postfix version 2.10.1
Mail injection command /usr/lib/sendmail -t
Apache version 2.4.6
PHP versions 7.0.33
Webalizer version 2.23-08
Logrotate version 3.8.6
MySQL version 10.0.38-MariaDB
SpamAssassin version 3.4.0



we also have 3 out of ~100 virtual servers without “fpm” option in Server Configuration->Website Options, while all others do. (!?) virtualmin cli also displays an error just for these 3 virtual servers when trying to switch. it’s all run manually now and working, but it’s strange…

Debian 9 fully upgraded, latest webmin/virtualmin. apache2, php5.6-fpm & official php7.0-fpm.

apache php module not installed, only cgi, fcgi & fpm. cgi/fcgi don’t actually work anyway, since they’re run by default as www-data without permissions on $home. (but that’s another bug i guess…).

ok, so i found the issue for our scenario & a fix. might be relevant to others as well…

these 3 virtual server had in their conf files (/etc/webmin/virtual-server/domains/$domain_id ) :
which is a leftover setting from previous php5 installed (from debian jessie iirc). we’re now running php5.6 and official php7.0, but somehow, it didn’t change for these particual virtual servers (one of which is the default site for host). it should be either:
to work correctly as all others.
changed that, and restarted webmin, seems to be working ok now… can see fpm option in their website options correctly.

1 Like