[SOLVED] Virtualmin Menus Disappeared

|**Operating system**|Ubuntu Linux 18.04.3|
|**Webmin version**|1.941|**Usermin version**|1.791|
|**Virtualmin version**|6.08|**Authentic theme version**|19.45|
**Firewall version** [ConfigServer Security & Firewall]14.01 
**Time on system** [Wednesday, January 22, 2020 5:31 PM]
**Kernel and CPU** Linux 4.15.0-74-generic on x86_64 *
*Processor information** Intel(R) Xeon(R) CPU E5-2650 v4 @ 2.20GHz, 40 cores
**System uptime** [15 days, 6 hours, 49 minutes] 
**Running processes** [517]
**CPU load averages** 0.22 (1 min) 0.18 (5 mins) 0.17 (15 mins) 
**Real memory** 3.42 GiB used / 9.79 GiB cached / 98.34 GiB total
**Virtual memory** 0 bytes used / 7.99 GiB total 
**Local disk space** 123.13 GiB used / 1.84 TiB free / 1.96 TiB total
**Package updates** [All installed packages are up to date]

So one day out of the blue all my virtualmin menus went away, now this is a new deployment with only two production sites on it currently. I see no error messages in the virtualmin or webmin logs and the last thing I ever did was install config firewall server, I did read about a dozen threads about this that pointed to authentic theme probems – I installed old versions via ftp, I installed latest stable, and I installed latest beta but no help.

Any thoughts on how to troubleshoot this?

Problem Solved, Apparently postfix was not installed for some odd reason. – that is wierd because the menus were working previously not sure what nuked my postfix

apt-get install postfix

solved my issue