[SOLVED] virtualmin install fails on aws

Just a note on an undocumented problem and how I solved it:

Using the default url (or named host address) Virtualmin fails to install with this error:

SyntaxError: Non-ASCII character ‘\xe2’ in file /var/lib/mailman/Mailman/mm_cfg.py on line 66

In /var/lib/mailman/Mailman/mm_cfg.py

changed ec2 named internal ec2 host address to numerical on lines 66 & 69

DEFAULT_EMAIL_HOST = ‘10.248.x.x’

DEFAULT_URL_HOST = ‘10.248.x.x’

(using a numerical elastic ip this shouldn’t be a problem).

It’s also necessary to create an initial mail list

sudo newlist mailman

Be sure to use the FQDN for email address of list owner (user@ec2.xxxxxxx.compute.amazonaws.com)

Post installation notes:

mysql cannot be accessed until you login (click provided link, login, then return to install)

“Primary nameserver cannot be resolved…”
checkbox “SKIP” (address not yet resolvable)

NOTE: use arrow keys to navigate ascii text dialogs, the spacebar to make selection, and tab to OK.

Install succeeded on Ubuntu 12.04 LTS.