[solved] ubuntu 7 install hangs-- Bad Substitution

Hello, hello!

Greetings from the unripened ranks of noobs.

I’ve purchased, downloaded pro, got Ubuntu 7.1 server running, and whipped out my Administrator’s Manual.

Then I settled in to try out the install.sh script, but it hangs at the following bit of code:

INFO - Removing Debian standard Webmin package, if they exist (because they’re broken)…
INFO - Removing Debian apache packages…
E: Sub-process /usr/bin/dpkg returned an error code (1)
INFO - Installing dependencies using command: /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip
INFO - …in progress, please wait…
/tmp/.virtualmin-6206/files/spinner: 11: Syntax error: Bad substitution

I let it sit here for over 20 minutes. A quick check showed 0% CPU usage and plenty of memory (400MB) available, which leaves me relatively certain it’s not out doing anything important in the background.

I tried a few searches in the forum but didn’t find any results. Anyone solved this in another thread that I can link up to? Any suggestions? Information I can provide that would help?

Kato<br><br>Post edited by: kato, at: 2008/08/06 06:50

Some problem… install script hangs…

You need 2 command screen to do this… And I sure I will be fixed at some point… But until then…

In one screen start the script… Then when the script dies, to a ‘ps -aux’ and find and copy the apt-get line process. Kill the install script on screen 1. You find the install script made folder /tmp/.virtualmin_something… from that folder run the apt-get command you copyed… It will do the the install, and ask some question like should the ftp be stand alone or inetd controlled… I picked stand alone. but the script is getting hung on some question like that… That my running by hand you can answer. At one point I had to hit enter that I put in the CD…
When the apt-get line is done running, I rerun the install script… I had to do that twice… but I wonted the install script to finish all the way so it could clean up…

I install it on a cheep test system, having that problem with 7.1 LAMP server and then I drop it to a same issues… Pick the for the first production HP server, and same issues. So that it 3 installs done… Now if I can figure out to to move 600 mail account I be happy…


Now my question :slight_smile:
Is there an easy way to uninstall the pro and then install the un-licensed version on my test system… I started getting a message " Your serial number is licenced for only 1 servers, but is being used on 3." Don’t know why 3 and not two, so I hit the kill switch my test system until that updates, Not sure how long that will be?? .And is that stopping stuff like the check, I trying to get BIND working.
But did the install script add apt-get stuff so a apt-get erase and apt-get install virtualmin just put back the same one? It may be easer to just wipe the system… It likes that…

I rolled back to Ubuntu 6.06 and the installer worked without a hitch. So far so spiffy!

New ISO "Ubuntu 6.06 LTS Server Edition" Installed the LAMP server… Run the setup line from the serials page and a hour later I see it was stuck doing an apt-get… (ps -auxf) When I run the apt-get from the folder with the apt.conf.noninteractive (/tmp/.virtualmin_something) I was asked a few question. I do remember on the 2nd apt-get one was if the ftp was standalone or inet controlled…
The system is and HP ProLiant ML Server. The first of 2 for now…
I had the same problem on my test system, it is just a clone type I use for just such stuff, I would do it again and take better notes, I waiting for my licence error to clear… best not confuse the licence counter at this point…


I waiting for my licence error to clear.. best not confuse the licence counter at this point..

Don’t fret too much over that–nothing happens until you’ve been running it on multiple servers for more than 30 days.

I’m looking into the Ubuntu problem…apt-get is really quite hostile to being run non-interactively (it’s the one thing I hate about Debian/Ubuntu systems). So, I’m doing everything I know how to do to make the rotten thing run without asking stupid questions and requiring human input, I guess it’s ignoring those options.

I understand… I am about ready to give up on Ubuntu for now.

I am trying to go with the flow, from where I am it looks like Ubuntu is the new hot thing now, and will be for some time, I own a small hosting company, and I have been running Redhat/CentSO, with a control panel I wrote ten years ago… So I am trying to move the 1000+ sites on a couple of server to the newest everything…

I run the servers remotely, and trying to learn/setup everything, I tried to install sendmail from the webmin control panel. It goes into a loop looking for the /cdrom/ to get something. So I need to figure that out, or find out the supported version of CentOS …


I run the servers remotely, and trying to learn/setup everything, I tried to install sendmail from the webmin control panel. It goes into a loop looking for the /cdrom/ to get something. So I need to figure that out, or find out the supported version of CentOS ..

Just disable any cdrom repositories in /etc/apt/sources.list

I try to do that in the install.sh, but I guess something has changed in the syntax that makes my substitution fail. It’s downright stupid that cdrom repositories are even enabled by default. It’s a “worse than failure” kind of moment for Ubuntu. Even SUSE is now smart enough to not expect a CD to be in the drive forever and ever.

(Ubuntu 6.06.1 LTS Server Edition - LAMP server)

The instalation script hanged after 20MB download (apt-get), by removing this line in /etc/apt/sources.list:

deb cdrom:[Ubuntu-Server 6.06.1 Dapper Drake

the problem was solved, thanks.

I checked out spinner, line 11… nothing too spectacular going on there…


#echo -n "${green} "
while [ -e $1 ]
echo -en "\b${sp:i++%${#sp}:1}" ## line 11
sleep .2
echo -en "${reset}\b"

But then, I don’t grok shell scripts… anyone see a problem with that line?

Post edited by: kato, at: 2007/11/21 18:28<br><br>Post edited by: kato, at: 2007/11/21 18:54