[SOLVED]Trying to get ssl certificate working

I have 2 installs of Virtualmin on 2 VPS’s. Both running latest yum updates on CentOS 6. So identical as far as I can tell. I have had an SSL certificate from PositiveSSL working on the one VPS for some time now. Never had problems installing it. Worked first time following the instructions on this site.

I am trying to get a second domain on the second VPS running with another PositiveSSL certificate and it refuses to work. The website continues to use the self signed certificate. I tried reissuing the certificate but that didn’t work. Tried re-installing the certificate multiple times, rebooting etc. Checked permissions. Checked http/ssl log files…no errors in there.

I’m stumped. I compared both VPS’s and they both appear to be identically configured so I cannot see anything I am doing wrong.

For anyone else having this problem here was the solution for me. Not sure if this is a bug or a feature or a quirk.

It must be because I only have one domain (virtualmin virtual server) on this server. My other server has multiple domains and I was able to install the ssl certificate for one of the domains that is not the default domain no problem with these same defaults.

On this server with the one domain that is therefore the default domain. I have to go to Webmin>Servers>Apache Web Server and click on the additional virtual server that is created by default at the bottom of the list. Not the “Default Server” at the top of the list. The one at the bottom with address “Any” and port 443 with document root of /var/www/html.

Not sure why Virtualmin creates that because as far as I can determine it’s not needed. Perhaps it’s there so people trying to access a non-existant domain can get a default page on /var/www/html or a CentOS landing page but if that’s the case why is it set to port 443 by default?

Anyways, If I click on that virtual server to get to the settings page and click on the “SSL Options” icon then Set “Enable SSL” to “NO” (make sure to “apply changes” after) my SSL certificate starts working. Seems to me a better default for that setting would be “NO” but the current default is “YES”. Doesn’t really make sense why VirtualMin/Apache ignores the signed certificate and uses the unsigned one for this internally created virutalmin virtual server but it does…if you only have one domain. Or perhaps it will also do this even if you have multiple domains and want to use a signed certificate on the default domain.

Update 2. After having some problems with postfix I think are related I believe the root cause is because my VPS was given the same FQDN as the primary domain which I know is not recommended.

@mustardman – Just wanted to chime in — 3 years later — to say thanks for your follow up post. It ended up being the solution to my issue as well.