[Solved] Theme broken - can't get back to virtualmin layout

Somehow messed up virtualmin so it always goes to Webmin theme. If I try selecting Authentic or Classic Framed all the image links are broken but the layout still looks like Webmin. Any way to reset this?

Server is Ubuntu 14.04 running latest Virtualmin GPL.
I was updating packages the other night and thought I would try out the mobile themes.
Log shows:
apt-get -y install usermin-virtual-server-mobile
apt-get -y install usermin-virtual-server-theme
apt-get -y install webmin-virtual-server-mobile
apt-get -y install webmin-virtualmin-dav
apt-get -y install webmin-virtualmin-signup

That messed something up with my themes. I recall that notice about the “New HTML 5 theme” coming up, and I said switch to it even though I was on authentic before.
Ever since I have been seeing nothing but a webmin layout.

I tried:

  • aptitude reinstall webmin-virtual-server-theme
  • deleting Authentic theme
  • apt-get removing all the mobile themes
  • installing Authentic theme from .deb
  • cloning Authentic theme master via git
  • installing Finally theme
  • changing theme from both Webmin configuration as well as User configuration
  • rebooting
  • different browsers, phones, ISPs
  • removing/re-installing virtualmin-base
  • muttering under my breath

Can’t get to anything but a webmin layout. All the components are still working. Mail/apache/etc, and I can still manage most of the services from the webmin theme. Can’t add new domains though.

Any ideas on how to force a reset of the virtualmin theme?


Hmm, could you share a screenshot of what you see when logging in?

Also, what user are you logging in as, are you seeing this issue with the root user? What about Virtual Server owners, do they experience the same problem?


Screen shots

That’s all with the root user. Virtual server owners see the same thing (broken images on white background that look like webmin).
I also tried copying over an existing /etc/webmin/webmin/config and /etc/webmin/miniserv.conf from another server to no avail.


Ugh, I had enabled the mobile theme that looks for m.* on a server named m.domain.
Fixed. That was aggravating.


I’m having the same issue here, https://www.virtualmin.com/node/54250
I didn’t get your solution though, you enable the mobile theme as the root user on a browser and that fixed it?
I tried that already but still get text only.