SOLVED: setting up FTP Backup - does not send.

Hello,

My server just crashed.
Yesterday I uploaded about 12GB to the server. The backup script backupped it … every hour.
After a day and a half the storage was saturated. The MYSQL of the site gave errors and it all halted.

I was lucky to still be able to remove the backups and keep 1, in order I needed it …
I decided I should not store backups locally.
At least not ONLY locally.

I installed a Filezilla FTP server at home, Set up a group with a homedir, and access to it
I added a user with access to it’s homedir.

I went to the router of my ISP, added the DMZ record and an additional port forwarding to the 2nd router
On the 2nd router I added port forwarding.
(port 21212)

So I went to the backup settings and added the FTP server.
After I set everything up and asked to test (backup now) it still makes the local backup, as required, but it fails in sending the backup to the ftp server.
I get this error:
… upload failed! Failed to connect to xxx.xxx.xxx.xxx:xxxx : No route to host

I’m sure I overlooked something or am plain stupid. Can anybody please guide me into the right way?

Thanks a lot

This might help:
the logs of the ftp server:

code4/02/2012 13:18:07 - (not logged in) (SERVER IP)> Connected, sending welcome message…
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> 220-BACKUP FTP
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> 220-somewhere.NET
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> 220 storage only
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> USER user
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> 331 Password required for user
(000005)4/02/2012 13:18:07 - (not logged in) (SERVER IP)> PASS **********
(000005)4/02/2012 13:18:07 - user (SERVER IP)> 230 Logged on
(000005)4/02/2012 13:18:07 - user (SERVER IP)> TYPE I
(000005)4/02/2012 13:18:07 - user (SERVER IP)> 200 Type set to I
(000005)4/02/2012 13:18:07 - user (SERVER IP)> PASV
(000005)4/02/2012 13:18:07 - user (SERVER IP)> 227 Entering Passive Mode (178,116,217,37,82,222)
(000005)4/02/2012 13:18:07 - user (SERVER IP)> disconnected.
[/code]

This happened at the initial of the backup where it’s testing the connection.

I’m finding that I forwarded the port 21212 but the PASV mode needs more ports so now I opened ports 21210 - 21219
hope this will work

it works now.
When working with filezilla keep this in mind:
activate passive mode and set a port range and also set your IP.

Today I learnt something new.

Great, I’m glad you got it working, thanks for letting us know how you resolved it!