(Solved) Sasl Auth Failure

Have Just installed virtualmin gpl on a debian 4.0 vps using the install script and am tranfering all services across to it from a dediacted debian 4.0 server however on the vps I cannot seem to authenticate smtp clients? Ive checked that the postfix.conf is the same on both bar the fact that the dedicated server would relay through another mail server and the default saslauthd conf is the same so im a little stummped?

heres a small chunk of the logged failure

warning: hostname host.domain.com verification failed: Name or service not known
connect from unknown[]
warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
warning: unknown[]: SASL LOGIN authentication failed: generic failure
lost connection after AUTH from unknown[]
disconnect from unknown[123.123.123]

further investigation using testsaslauthd shows sasl to be working but postfix is not communicating with the service any ideas?

Looks related to this thread http://www.virtualmin.com/index.php?option=com_fireboard&Itemid=77&func=view&id=8734&catid=8#8734
but script fails when reaching the sasl configuration?

Turned out to be permissions on /var/spool/postfix/var/
chowned to root:sasl solved the issue<br><br>Post edited by: razmirz, at: 2008/01/05 15:20