[Solved] Partially completed backup of Virtualmin

Hi,

I run 3.74.gpl GPL on Debian Lenny dedicated box.

I have several Virtual hosts I need to backup to an FTP server. Everything works great, backup are performed as long as Apache (and virtual hosts) is configured to listen on 80 port.

I changed that behaviour, because I installed a reverse proxy. So now Apache listens on port 8080 and my scheduled backups are only “Partially completed…”

And the only errors Virtualmin is showing is:

... Creating TAR file of home directory .. .. done

1 servers backed up successfully, 5 had errors.

Servers with errors: foo0.bar.com foo1.bar.com foo2.bar.com foo3.bar.com foo4.bar.com
Deleting backups older than 30 days …
… no backups to delete were found

Backup is partially complete. Final size was 1.15 kB. Total backup time was 00 minutes, 31 seconds.

Virtual servers that failed :
foo0.bar.com
foo1.bar.com
foo2.bar.com
foo3.bar.com
foo4.bar.com
Sent by Virtualmin at: https://bar.com:10000

Anyone already experienced this knid of problem?

Many thanks!

Jérémy

Just noticed this error on backup log for each of the virtualhosts that fail:

Copying Apache virtual host configuration .. .. no Apache virtual host found!

Ok finally solved see http://www.virtualmin.com/node/9770