[SOLVED] New Install php Problem

Howdy :-),

i just installed Virtualmin with the script i downloaded today and am wondering about php.

If i run phpinfo i get a blank page. I also installed roundcube 1.1 with the included script and if i run it the browser tells me this:

| +-------------------------------------------------------------------------+ $Id$ */ 
// include environment require_once 'program/include/iniset.php'; 
// init application, start session, init output class, etc. $RCMAIL = rcmail::get_instance(); 
// Make the whole PHP output non-cacheable (#1487797) send_nocacheing_headers();
 // turn on output buffering ob_start();
 // check if config files had errors if ($err_str = $RCMAIL->config->get_error()) { raise_error(array( 'code' => 601, 'type' => 'php', 'message' => $err_str), false, true); } 
// check DB connections and exit on failure if ($err_str = $RCMAIL->db->is_error()) { raise_error(array( 'code' => 603, 'type' => 'db', 'message' => $err_str), FALSE, TRUE); } 
// error steps if ($RCMAIL->action=='error' && !empty($_GET['_code'])) { raise_error(array('code' => hexdec($_GET['_code'])), FALSE, TRUE); }


i know, this is the content of the index.php from roundcube.

I assume it is a setting anywhere, which i can’t find at the moment. If i open the php settings in Webmin it is there, i deactivated suexec and also use mod_php. The phpmodule is activated in Apache, so i am a little out of my wits.

Any idea?

Thanks and best

PS: Interestingly enough, ichanged some values in PHP setup like error logging and show errors, which doesn’t change anything.


Hmm, what distro/version are you using?

And are you saying you saw this problem both using the default PHP Execution Mode, FCGID, as well as in mod_php?


It made me crazy, the index php script from roundcube would show source, whatever version of roundcube i installed, php5 was working, the apache2 module for php5 was enabled, and the phpinfo file would just generate white screen. Best of all no php logfile being written. I suspected virtualmin, that it didn’t write back the changes to php.ini. But it did, and no avail. Just being curious i checked all files around php5 and apache and fell over the file /etc/apache2/mods-enalbed/php5.conf.

i saw this:

# SetHandler application/x-httpd-php

and changed it to that:

SetHandler application/x-httpd-php

which did the trick after a

service apache2 restart

After fixing that, i remembered i had this one a year ago or something. and i am wondering, why this directive isn’t enabled, although php has been installed.

You know, if you are behind a problem, sometimes you don’t look for the obvious and need to be pushed into the right direction.

Where does it come from? Is it an ubuntu “speciail”?

Best and thanx