[SOLVED] ERROR: "Failed to save mailbox : Unknown file mode >"

i’m using Virtualmin and all seems working except this:

when i create a new virtual server user inside an already existent VS…
this error appears
Failed to save mailbox : Unknown file mode >

the user, anyway, is created as usual…
i need it when i have to add an email account

but is this relevant and can cause something bad? and what’s the source of this issue?

thank you very much

CentOS 6.5 | Webmin 1.710 SSL | Virtualmin 4.02.gpl

notice: can be due to suexec disabled and “Permissions on website directory” 750 ?


Hmm, I haven’t run into an error like that before. Does the email account work? Are you able to send email to it?

Once thing you may want to try though is to upgrade to the most recent Virtualmin, just to make sure you aren’t seeing a bug… the version you’re using there is a bit older.


ehy, thank you… yes, the email account works…
but how is possible that i don’t see the update?
that is, i didn’t even know that it was updated to October 2014…
how to upgrade on Centos? download and install as module ?


How was your initial Virtualmin installation performed? Was that done using the install.sh script?

Virtualmin 4.02 was from August 2013 though, there’s been a number of updates since that time.


i don’t remember… i think to have installed Webmin before and then Virtualmin as module, like now…

updated to 4.11 but the error is there

Failed to save mailbox : Unknown file mode >

after the error the user is on the list and the email works but i would understand what’s this…

maybe do you need some info?

is it related to cgi ? i don’t have php-cgi installed… never used, and to my knowledge is not a must to execute cgi…otherwise i couldn’t even use Virtualmin, isn’t it?

why there is not a “Virtualmin log activity” or such like that? IYO what’s the problem with save_user.cgi in /usr/libexec/webmin/virtual-server/save_user.cgi ? thanks

other issue: the user created by the virtual server template has NO permissions to create a database…
i looked into everything and can’t find option to do it…

when he logins he can: create a table on the default database, backup and exe sql… STOP

then, installing phpmyadmin from install script does nothing, he CAN’T create database…

how to fix?

CentOS 6.5 | Webmin 1.710 SSL | Virtualmin 4.02.gpl | Authentic Theme 4.1.2

p.s.: OK, i found where he can create a database…
has to enter Virtualmin and Edit Database…
BUT in phpmyadmin has NO permissions… why? IMO for an ideal & correct implementation, if the template is done to make him login you should also make a routine to give him privileges to create a database until the N. limit of databases he can create, 'cause phpmyadmin “does not handle user management”. So you should do it automatically by root before the phpmyadmin installation. Otherwise phpmyadmin is useful only to manage the first database and then he’s forced to login into Virtualmin to create a database. Maybe this needs a cron or else? Don’t you agree? I don’t think that’s difficult to do it on your side…it’s enough to automatically login to mysql and give the privileges…
then, it would be great if Webmin/Virtualmin had a url language linking as e.g. whmcs… so if someone has clients from more countries can complete the missing translations with module translator etc… and address users directly to their language…

and please can you tell me what can cause that error in topic? thanks

I am getting the same error message when creating users.

Failed to save mailbox : Unknown file mode >

This started this weekend. I am also using CentOS 6.5 and used the install.sh script.

i found that the problem is the Authentic Theme, even the latest version 4.1.7

with the default theme it doesn’t return that error

I updated the Authentic Theme when this error started. Thats it!

Confirmed and fixed in version 4.2.0. Please update.

Thanks for pointing at the bug.

I updated to 4.2.0 and it all works now. Thanks for the update, my clients love the Authentic theme!

Is this related? Are they the same/related theme?
Would we need bootstrap 3 theme updated?
What were the changes needed?

Those are not the same anymore. In case you want to find out, the best shot is to take a look at the diffs on GitHub.