[SOLVED] DNS validation failed, even though MX records are in correct format

Isn’t this the correct format:

domain.tld. IN A xxx.xxx.xxx.xxx
mail IN A xxx.xxx.xxx.xxx
domain.tld. IN MX 5 mail.domain.tld.
domain.tld. IN TXT “v=spf1 a mx a:domain.tld. ip4:xxx.xxx.xxx.xxx ?all”

Yet when saving I get:
Failed to save DNS records : Validation failed : This domain has email enabled, but none of the MX records point to it. Either the MX records should be corrected, or the email feature disabled if mail is hosted externally.

I can send mail just fine, iptables is ok and ports 25, 110, 143 are listened. DNS works fine otherwise (website works).

I’m using OVH Hosting’s Kimsufi dedicated server. The mail worked OK with OVH’s automatically generated domain before I assigned a proper domain.

I have to say I have been impressed with Virtualmin/Webmin and how easy and clear everything is to set up. It takes a lot of the pain away from getting into new things without obstructing learning.

I tried also with just this in place of the three mail-related entries:

domain.tld IN MX 5 ovh-generated.domain.eu.

Then it passed validation, BUT I get “undelivered mail” when testing and it says “mail for ovh-generated.domain.eu loops back to myself”.

Ah, ninja-edit: I ran “re-check config” and it said: our Postfix configuration is missing the system’s mail hostname ovh-generated.domain.eu from the mydestination line, which will cause mail to bounce.

Edit2: so I went to Postfix - General options - “What domains to receive mail for” and entered the proper info (it had a completely wrong domain name in it) and IT WORKS (with the ovh-generated domain as the MX, that is)!!