[SOLVED]Creating new virtual server/Sub-server doesn't share the IP address

Howdy,

I’m using Virtualmin for past 3 to 4 years without any issues.
I have 3 domains and several subdomains in Virtualmin which works fine.
For the past 1 year, I didn’t do any server maintenance except for updating the packages which shown in the Webmin control panel.

PROBLEM

I tried to add a subdomain(Sub server) for an existing domain.
Now all the domains and subdomains point to public_html of the newly created virtual server or sub-server.

Eg: If I want to add a subdmain/Subserver to www.example1.com all the other existing domains and subdomains points to
/home/example1/domains/test.example1.com/public_html

Or If I create a new virtual server for www.example2.com all the other existing domains and subdomains points to
/home/example2/public_html

Webmin -> Apache Webserver -> Existing virtual host looks like this.

Virtual Server Any 80 medlk.myolddomain.com /home/abcd/domains/medlk.myolddomain.com/public_html
Virtual Server Any 80 mydocs.myolddomain.com /home/abcd/domains/mydocs.myolddomain.com/public_html
Virtual Server 128...334 80 test.myolddomain.com /home/abcd/domains/test.myolddomain.lk/public_html

The newly created virtual server doesn’t share the IP address.

To resolve it, either I have to,

  1. Delete the new virtual server that I have created or
  2. Edit virtual server -> Enabled features -> DISABLE Apache website (Remove check mark)
  3. Change the IP address

I have no clue about what is wrong.
I would really appreciate your advice on approaching this problem.

Thank you

Howdy,

RESOLVED

For now I have resolved the issue by editing,
/etc/apache2/sites-available/xxxx.conf

The change I made in the first line,
<VirtualHost 128.xxx.xxx.227:80>
Changed it to,
<VirtualHost *:80>

PROBLEM

I just wonder why Virtualmin is not adding “*” when creating a new virtual server or subserver?

Thank you.