[SOLVED]BIND does not transmit updates

Either I’m doing something wrong in my configs, or … something else. I don’t know anymore.

I have a centos 6.4 with virtualmin 3.99.

I added a record for a sub domain 2 or 3 weeks ago, and it has still not resolved with other DNS servers. (When I do a nslookup for that sub domain, no server can find it)

The server is up and running. The 1st dns is pointing to that server.
What could be wrong?


Apparently I also get this:
Non-authoritative answer


You may want to try running a DNS report using intodns.com, that may give you some clues as to what’s going on.

You could also review the logs on all your servers to see if there’s any BIND errors being listed in any of them.



Thanks. That will help me a bit. Seems like the nameservers are not 100% correct. I’ll check when I get home and update :slight_smile:

Well, I learned a few new things about DNS today. Thanks Eric.

Though I do get the following notice:
SOA Serial Your SOA serial number is: 1364390160. This can be ok if you know what you are doing.

Since I have no idea what I’m doing … why do I get the message?


WARNING: Your SOA serial number is: 1043861206. That is OK, but the recommended format (per RFC1912 2.2) is YYYYMMDDnn, where ‘nn’ is the revision. For example, if you are making the 3rd change on 02 May 2000, you would use 2000050203. This number must be incremented every time you make a DNS change.


That SOA noticed is safe to ignore… Webmin/Virtualmin is setting it up that way intentionally.

I’m glad everything else is working well!