SOLVED- 1.830 update broke webmin on all my servers


After updating to latest version of webmin (1.830) it became impossible to log in to webmin; after entering the username/password it says “Error” in page title, and only displays a gray screen. This issue happened on multiple, unrelated, centos 7.3 systems (centos 6.8 remained functional). I’ve tried restarting the webmin service, and even rebooting, with no success. It’s not browser related, as it does the same with multiple browsers.

systemctl status webmin -l
  • webmin.service - LSB: Start or stop the Webmin server
    Loaded: loaded (/etc/rc.d/init.d/webmin; bad; vendor preset: disabled)
    Active: active (running) since Wed 2017-01-04 02:05:18 EET; 10min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 1361 ExecStop=/etc/rc.d/init.d/webmin stop (code=exited, status=0/SUCCESS)
    Process: 1398 ExecStart=/etc/rc.d/init.d/webmin start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/webmin.service
    `-1400 /usr/bin/perl /usr/libexec/webmin/ /etc/webmin/miniserv.conf

Jan 04 02:05:17 systemd[1]: Starting LSB: Start or stop the Webmin server…
Jan 04 02:05:17 webmin[1399]: Webmin starting
Jan 04 02:05:18 systemd[1]: Started LSB: Start or stop the Webmin server.

If the same thing happened on multiple servers you should open a ticket and report a possible bug. Still on my test server with Centos 7.3 i didnt notice any problem.

This update worked fine for me, I did it yesterday… I’m sure it doesn’t help you, but wanted to let you know, I Do a snapshot, EVERYTIME, before any update even “VIM” Update last week, Using CentOs 7.


There was another report recently about a similar problem with this release; I haven’t seen it myself (it seems to be related to CSF firewall being installed, and some missing files in the Authentic theme), but Ilia has figured out why it’s happening and we’re rolling a new Webmin tomorrow that fixes it.

In the meantime, I believe the workaround is to just create an /etc/webmin/authentic-theme directory:

# mkdir /etc/webmin/authentic-theme

It’s kinda bug-like that Authentic would fail to render the page without that being present and without providing a good error message, and I think that’s fixed properly in the next version.

Another user opened a ticket here

The solution is

                    mkdir /etc/webmin/authentic-theme
                   chmod 711 /etc/webmin/authentic-theme