Software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease' doesn't support architecture

Hello Team,

Do you have any suggestion on how to go about this error message?

N: Skipping acquire of configured file 'main/binary-amd64/Packages' as repository 'http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease' doesn't support architecture 'amd64'

N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease' doesn't support architecture 'i386'

cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.6 LTS"
NAME="Ubuntu"
VERSION="16.04.6 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.6 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

I can see similar thread, however, no fix yet.

I can see a maintenace has been made,

however, I would like to know if Xenial repository has been fixed already?

already run, but no changes yet.

sudo apt-get clean
sudo apt-get update

Any advice?

Same problem here, Debian 9

xx:~# sudo apt-get clean
xx:~# sudo apt-get update
Ign:1 http://debian.mirrors.ovh.net/debian stretch InRelease
Get:2 http://debian.mirrors.ovh.net/debian stretch-updates InRelease [91.0 kB]
Hit:3 http://security.debian.org/debian-security stretch/updates InRelease
Hit:4 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-stretch InRelease
Hit:5 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease
Get:6 http://debian.mirrors.ovh.net/debian stretch Release [118 kB]
Get:7 https://last-public-ovh-kernel.snap.mirrors.ovh.net/debian ovhkernel InRel ease [4,944 B]
Hit:8 https://packages.sury.org/php stretch InRelease
Fetched 214 kB in 3s (65.3 kB/s)
Reading package lists… Done
N: Skipping acquire of configured file ‘main/binary-amd64/Packages’ as repository ‘http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease’ doesn’t support architecture ‘amd64’

@Joe is already aware of that, at least I assume that from his posts here: Software Repository Maintenance.
It was fixed but re-appeared today, but from what I read here Virtualmin module updates it seems like there are new issues.

My guess: wait till Joe fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.