SMTP Ports

Does virtualmin+webmin gpl come with both port 25 and port 587 enabled out of box? I can’t seem to find any port configurations anywhere in the backend and i’ve found it hard to find it in the forums. In the email setup/pop3 docs it has port 587 listed so i’m assuming it’s already pre-inabled. If so, i won’t even mess with it. I’m going to setup an email and try it, but if someone could tell me in the meantime that would be great!

Also, is authentication already setup or do is set that in Sendmail Mail Server >> network ports or somewhere else? I basically just want to setup a healthy mailserver with authentication and port backfall.



Which distro are you using?

If you’re using Debian or Ubuntu, you may just need to uncomment the SMTPS and Submission sections in /etc/postfix/

If you’re using CentOS, you’d first need to setup an SSL cert and copy it to Postfix, before port 465/587 would work.


i’m on centos. how would i setup an ssl certificate? is this the kind that I don’t need to purchase?


Yeah, you can do all that with a free, self-signed certificate. It’s just that CentOS doesn’t setup one by default.

Take a look at the second to last comment in this thread here:

In there, how to setup an SSL cert for Postfix and Saslauthd is described, which would allow you to enable ports 587 and 465.


ok, almost there

in /etc/postfix/,

is this correctly uncommented?

smtp inet n - n - - smtpd -o smtpd_sasl_aut$
submission inet n - n - - smtpd
-o smtpd_enforce_tls=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
smtps inet n - n - - smtpd
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628 inet n - n - - qmqpd

Yup, that looks right!

For that to work, you’d have to have setup the SSL cert from within Virtualmin, as well as restart Postfix. But if you do all those steps, that should work well for you.


yeah i followed those other steps before hand for installing ssl on the vserver and i just saved those changes and restarted postfix successfully. Thanks!