smtp on 25 doesn't work...

Hiiii there!

I’ve read several topics about my issue but… no solutions…

and this is:

I’ve just made a virtual server. Everything works very good: website, webmail, Client on Outlook for incoming messages… everything.
The only one thing who doesn’t work is the Client on Outlook for outgoing messages… They stay in the “post exit” folder on Outlook.

So I’ve checked everything about the ports and the 25 is open as smtp so… what doesn’t work?

I’ve also checked which program are using the ports and the 25 is used by “master” and not by “dovecot”… could be that one the issue? What is “master” as program?

Here follow the results lunching # netstat -tulpn :
(I’ve changed “MYIP” to avoid to declare which ports are open on my server. Is it correct to avoid to be exposed?)

# netstat -tulpn Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 2878/dovecot tcp 0 0 127.0.0.1:3310 0.0.0.0:* LISTEN 2685/clamd tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 2878/dovecot tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 3123/perl tcp 0 0 MYIP:53 0.0.0.0:* LISTEN 2610/named tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 2610/named tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2668/sshd tcp 0 0 127.0.0.1:11000 0.0.0.0:* LISTEN 3095/lookup-domain- tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2968/master tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 2610/named tcp 0 0 0.0.0.0:20000 0.0.0.0:* LISTEN 3101/perl tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 2878/dovecot tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 2878/dovecot tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 2855/mysqld tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 2968/master tcp 0 0 :::110 :::* LISTEN 2878/dovecot tcp 0 0 :::143 :::* LISTEN 2878/dovecot tcp 0 0 :::80 :::* LISTEN 2988/httpd tcp 0 0 :::21 :::* LISTEN 2981/proftpd tcp 0 0 :::53 :::* LISTEN 2610/named tcp 0 0 :::22 :::* LISTEN 2668/sshd tcp 0 0 :::25 :::* LISTEN 2968/master tcp 0 0 ::1:953 :::* LISTEN 2610/named tcp 0 0 :::443 :::* LISTEN 2988/httpd tcp 0 0 :::993 :::* LISTEN 2878/dovecot tcp 0 0 :::995 :::* LISTEN 2878/dovecot tcp 0 0 :::587 :::* LISTEN 2968/master udp 0 0 0.0.0.0:783 0.0.0.0:* 2564/portreserve udp 0 0 0.0.0.0:20000 0.0.0.0:* 3101/perl udp 0 0 0.0.0.0:10000 0.0.0.0:* 3123/perl udp 0 0 MYIP:53 0.0.0.0:* 2610/named udp 0 0 127.0.0.1:53 0.0.0.0:* 2610/named udp 0 0 :::53 :::* 2610/named

What should I do in your opinion?
Maybe allow even the udp protocol for the port 25?
Or should I change the program who is using the port from “master” (which I’ve no clue for what it’s used by the system) to “dovecot”?

Thaaaaaaaaanks!

Howdy,

It looks like Postfix is running on your server. The program “master” is part of Postfix.

What port is Outlook configured to connect to, is it port 25, or another port?

When sending a message to your server, you may want to look in the email logs to see if any errors show up, or even if there’s a connection attempt at all. Those are available in /var/log/maillog, or /var/log/mail.log, depending on your distro.

-Eric

Hoiiiiiiiiiiiiiii mmmaaaaan!

I’ve solved it:

just changing on Outlook the door 587 instead the 25.

Fixed!

I hope it will be useful for other people cause I saw several topics with no so easy solution. That’s it!

Thank Youuuuuu
byeeeeeeeeeeeee

have you checked your firewall? If you will not be using port 25, I do not recommend it to be open.

it’s a very good point!
Thanks: I’ll close the port!