SMTP issues

We have a client trying to use our Virtualmin server as a SMTP server. We can not get Outlook configured to authenicate and send out mail.

We have checked the dovecot.conf file and it looks to be set to allow plain text passwords.

Rick

Hi William,

I think of three possible things:

  1. Firewall settings, check port 25
  2. SASL Authentication (should by setup by default, I think)
  3. In Sweden where I live all ISP’s have closed the use of SMTP port 25 on all conestions other than to their own maiserver, to force you to use the ISP’s SMTP relay, this to have control of all spammers out there. I added a port on our server that we can use instead of port 25, and of cource added the port to the firewall.

Regards,
Leif

no firewall blocking…and my colo provider doesn’t block anything. i’ll have to look at SASL authentication.

Hi,

My “Restrictions on recipient addresses” in “Postfix Configuration - SMTP Server Options” was a problem for me at start, but I think the settings for SASL authentication is fixed and should be configured from install now. Our server got a fresh install some month ago due to a hardware problem resulting in a harddisk crash and I’m not shure if I have changed anything in my SASL authentication settings this time. Anyway I use these options in “Restrictions on recipient addresses”:
permit_mynetworks permit_sasl_authenticated reject_unauth_destination

You have probably allready checked that your mail-client set to use authentication.

Regards,
Leif (just a regular user)

i am using sendmail BTW

Hey William,

So, it’s not Virtualmin Professional? (I’m guessing. Professional only sets up Postfix, though it’s possible to switch to Sendmail–but the install.sh doesn’t automatically configure it.)

If it’s not Professional, you’ll have to configure SASL yourself no matter what MTA you’re using. I’m afraid I don’t actually know, off-hand, how to configure it for Sendmail…so I can’t really give you any pointers.