smtp auth

Hello i must be alone with this problem, i hope someone can help. i have a new install of FC5, the virtual pop accounts can recieve mail using user@domain.tld, sendmail using the webclient squirrel mail, but we cant relay using a fat client. yes the outlook settings are correct. the message.log says;
mail saslauthd[[1886]]: do_auth : auth failure: [[user=user]] [[service=smtp]] [[realm=domain.tld]] [[mech=pam]] [[reason=PAM auth error]]
i am able to relay useing auth when i use the unix account created during the virtual setup. am i missing something in the Docs?

Hey Bill,

Your account names have @ in them, correct? If so, the SASL version on FC5 does not accept them by default (we’re fighting “Best Practices” when we use @ in the username…and so all of the software in the stack fights against us a little). You have to follow the instructions in the “usernames with @” FAQ found here:

http://www.virtualmin.com/faq/one-faq?faq_id=1511#51230

The third paragraph is the one you’re after. Basically, you just need to add “FLAGS=-r” to /etc/sysconfig/saslauthd.

We’ll handle this automatically during installation soon…I just need to figure out which operating systems this applies to (the option doesn’t exist on older versions of SASL, so we can’t just modify everybodies configuration).

worked like a charm!!
i knew i missed something in the docs.

THANKS AGAIN

Hello, I’m having the same problem but the link says “Page not found” any suggestions?