Slow ftp message

I never did get this topic resolved and it is buried in here… I can’t find it… so I’ll post it again.

My ftp message takes at least 30 seconds to show up after connection…

Status: Connecting to…
Status: Connection established, waiting for welcome message…

----30 second wait----

Response: 220 ProFTPD 1.3.1 Server (Debian) [::ffff:]

what can be causing this? :slight_smile:

is it just as slow when you connect to the LAN IP? Assuming your PC is behind the same router as your server, i.e same network

yes it is just as slow from lan, unless i use on lan…

HELLO!? This isn’t resolved, and it’s quite annoying, I’ve tried active and passive from WAN side. It’s still slow.

i can only think of dns issues. is your router mentioned as a nameserver in network settings - ?

I’m pretty sure it’s set up as a gateway.

as a gateway is good but you also need it as a nameserver…in networking settings module.
Im not sure about your set up but your IP has a lot of dns issues when running a dns check on it…

what check are you running?
let me look at my ifconfig and see if its set as a nameserver


I’m guessing my slow ftp message is something to do with dns-search?


Put this in your /etc/proftpd.conf:

UseReverseDNS off

IdentLookups off