Site fails to load

The site is hosted in www.mktconnection.com.br with all its content and opening properly. Poerem they pass some minutes browsing the site, it looks like being offline does not have content in public_html folder. Someone told me that this problem is in mod_fcgid: read data timeout in 31 secounds. Where can I increase timeout and request mod_fcgid team to get my website online without any problems??

Increase your mod_fcgid please request timeout and team

Howdy,

You can increase the timeout by going into Server Configuration -> Website Options, and in there, set “Maximum PHP script run time” to a higher value.

-Eric

Unlimetd? ? seconds? that value in March? how many lay Seconds?

That’s right, and the main list of PHP limits you get with “Services -> PHP5 Configuration -> Resource Limits”.

You wouldn’t really want to set this to “unlimited”. That could cause a PHP process to hang forever if something goes wrong. You should set it to a finite value that’s safely beyond anything your sites need, but only as high as necessary.

set to 120 sec however the error remains …

What error exactly are you seeing and when exactly? Please post a log excerpt. Also make sure to edit the correct php.ini and restart Apache afterwards.

Another thing you could try, is to see if you get the same problem while using CGI.

You can change that by going into Server Configuration -> Website Options, and there, change the PHP Execution Mode to “CGI”.

After doing that, does the problem you’re having still occur?

If so, let us know what error(s) you’re seeing in $HOME/logs/error_log.

Sometimes, additional error messages (and more helpful error messages) can show up when using CGI mode, that don’t show up when using the default FCGID mode.

-Eric

[Fri Mar 07 17:03:41 2014] [warn] [client 148.251.57.90] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Fri Mar 07 17:03:42 2014] [error] [client 148.251.57.90] Premature end of script headers: json.php

hello hello

Please don’t be impatient, we can’t sit here all day (night) monitoring this forum.

Your log excerpt shows no sign of PHP execution timeout. Please verify that, post complete log excerpts from your attempts, and perform ALL the steps Eric suggested.

I am calm and patient. And you, this nervous?

Alrighty, I don’t think we need to discuss any further on this level. :slight_smile:

Since you’re apparently not interested in our advice - since you’re not answering our questions or follow our suggestions, I unfortunately can’t help you further. Eric might be able to. Hope you get your issue resolved!

Let us know what happens when you try the steps I mentioned in my last comment above.

If you get an error at all, it would be a different error, as it would no longer be using FCGID in that case.

-Eric