Setup Virtualmin on Amazon EC2 instance for autoscaling

Hello all,

I’ve installed Virtualmin on an Amazon EC2 instance. This instance will host only one domain.
For it to work I had to use the instance’s private IP address on the virtualserver configuration. Otherwise the default website (/var/www/html) would be shown when accessing domain.
Now I’m setting up EC2 for autoscaling, and when I run a copy of that instance it gets another private IP, and the default website (/var/www/html) is again shown instead of my domain.

To fix it, I maually edited the /etc/httpd/conf/httpd.conf file, and changed the virtual host configuration as follows:

<VirtualHost 172.31.17.142:80>
SuexecUserGroup "#504" "#504"
ServerName plugpecaws.intercode.net.br
...

to

<VirtualHost *:80>
SuexecUserGroup "#504" "#504"
ServerName plugpecaws.intercode.net.br
...

I changed the private IP address to *.

Now it works when run a copy of that instance.

Questions:

  • Is that the right way to do it?

  • Is there a way to configure a virtual server to use ANY IP address on the Virtualmin interface?

  • Can I have any problems with this setup?

  • The webiste will have HTTPS/SSL certificate… can I do the same and edit the the config file?

  • If I edit the virtualserver on Virtualmin, will I loose the edit I did manaully?

Any help will be greatly appreciated

Thanks

  • Rogerio

Anyone pls?