Setting a different Document Root in template doesn't work

I’m new to Virtualmin and apache. I want to change the document route for my virtual servers when creating them. I have gone into server templates and changed under apache webserver>Users’ website subdirectory to create and changed it from the default public_html to public. When I create the virtual server it does create that directory in place of the public_html directory but the website does not work. When I look at the apache virtual config it still shows the document route as public_html. I either have to edit the config file, or go to Server Configuration > website options and change Website documents sub-directory to public for it to work. Is there no place in the template to set this? Have I missed something?

Ubuntu Linux 18.04.3
Webmin 1.930
Virtualmin 6.07
Apache 2.4.29