Set up queries

I have the two queries below when I check the configuration. It is telling me that virtualmin is OK to use. How do I change these and will they make a difference to setting up new servers if they are not changed?

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled.

Shell /bin/false for FTP users is not included in /etc/shells, which may prevent FTP access.

Thank you

So you didn’t install using the automated install script…there’s probably some other stuff that you’ll want, but isn’t configured or installed. If this is a new box, not production yet, and it’s one of the operating systems supported by our install script, I’d suggest you start over and use the install script. It’ll save you a lot of time and frustration later.

If you really do want to do everything manually:

Enable quotes on the / filesystem. You can use the Webmin System:Disk and Network Filesystems module to enable quotas on the filesystem, and then the Disk Quotas module to actually start them up.

As for the shell warning…you need to add "/bin/false" to /etc/shells, if you want FTP-only access to work.

I thought I had done it automatically. I had first installed the free version then used the upgrade to install the paid version.

I am really new to doing this sort of thing - what do I need to do to start over and re install. My operating system is CentOS Linux 5.2.

Thanks for your help.

what you want to do is to reinstall the OS with a minimum.
Just the server part and no apache, no mqsql etc.
Once done do a ‘yum update’

then get the link from your account: http://www.virtualmin.com/serial/ <- log in there and copy the url with your serial number and paste it in the putty screen.

that is how I did it and my system is still up and running

Thank you both for your help and advice.

I in the end changed the two things that Joe suggested and was amazed that I actually managed to do it. No errors showing now.

I would have tried the other option had that not worked but was only worried that I wouldn’t be covered by my support if anything was to go wrong.

Thanks again.

Sorry I have a couple of other queries.

Everything seems to be set up OK now but I seem unable to start the mail server and ftp. They still show red cross.

When trying to start sendmail I get this error.

Failed to start service :

Starting sendmail: [ OK ]
Starting sm-client: exim abandoned: unknown, malformed, or incomplete option -L
[FAILED]

Is send mail the best option to use or should I use another email program.

Nothing seems to happen when I try and start the ProFTPd server - the page refreshes and that is it.

Any help would be appreciated.